Estoy intentando enviarme a iTunes Connect con Xcode 6.4. Estoy recibiendo este error

No se puede validar su solicitud
La aplicación que ha seleccionado no existe.

Puedo encontrar el perfil de aprovisionamiento a través de mi cuenta de desarrollador en el paso anterior. He verificado todos los identificadores. También probé Application Loader y obtuve básicamente el mismo error. Lo extraño es que envié otra aplicación varias horas antes a la misma cuenta sin problemas. Cualquier ayuda será muy apreciada.

ingrese la descripción de la imagen aquí

5

Probé Application Loader y funcionó. No funcionó 2 horas antes. Lo extraño es que intenté descargar una aplicación de la App Store y no pudieron encontrar mi cuenta. Aparecieron algunos términos de servicio nuevos y acepté. Después de eso, pude descargar con la cuenta «inexistente» anterior. Fue entonces cuando probé App Loader y funcionó. Debe haber algo del lado de Apple que se arreglará en breve.

15

Estaba teniendo el mismo problema, esto es lo que hice para enviar la aplicación a la tienda de aplicaciones:

En XCODE create, genere el «Archivo», una vez que obtenga la ventana / ventana emergente «Organizador», valídela como lo hace normalmente. Si está validado, haga clic en «Exportar» y seleccione «Guardar para la implementación de la tienda de aplicaciones de iOS». Guárdelo en algún lugar y tome nota de esta ubicación, necesitará el archivo IPA.

Instale el «Cargador de aplicaciones» desde https://itunesconnect.apple.com/apploader/ApplicationLoader_3.1.dmg, si aún no lo tiene.

Siga los sencillos pasos para enviar la aplicación a la tienda de aplicaciones. Eso es «Entrega tu aplicación», selecciona el archivo IPA y ¡listo!

¡Espero que esto ayude!

6

Mientras que otros están teniendo éxito con Application Loader, yo no lo hice y recibí un error diferente «No está autorizado para utilizar este servicio» ¡Excelente!

Dado que iOS 9.1 se lanzó ayer, tal vez Xcode 6.x se esté eliminando gradualmente, pero no estamos listos para migrar a Xcode 7.x para este proyecto en particular.

Tuve éxito al archivar en Xcode 6.xy usar el Organizador en Xcode 7.1 para enviarlo a la App Store. El procedimiento es el siguiente:

  1. Cambiar el nombre de Xcode 6.x (en mi caso Xcode632.app).
  2. Descargue e instale Xcode 7.1 desde el archivo .dmg, no como una mejora.
  3. Cree y archive su aplicación en Xcode 6.x
  4. Cierre Xcode 6.x
  5. Inicie Xcode 7.1 pero no abrir tu proyecto.
  6. En Xcode 7, seleccione Ventana-> Organizador.
  7. Enviar a App Store.

Con suerte, esto te ayudará si fallan las cargas de Xcode y Application Loader.

2

Descargue Xcode 7 e intente cargar una nueva compilación, asegúrese de haber cambiado la versión o (y) el número de compilación de la aplicación, debería funcionar.

5

Exportar y cargar a través de Application Loader funcionó para mí.

3

ACTUALIZACIÓN: Parece que Apple ha solucionado este error. Acabo de subir con éxito una compilación usando Xcode 6.4 a iTunes Connect. Creo que esto fue un error del organizador o un error de iTC, pero lo han solucionado.

Antes, la solución era utilizar el cargador de aplicaciones.

Debería poder enviar usando Xcode 6.x ahora. Necesitamos cargar la compilación desde 6.x porque Xcode 7 requiere mucha refactorización debido a ATS. El estándar «AllowArbitraryLoads» no es suficiente para mi proyecto.

Parece que esto puede deberse a una nueva lógica de validación del número de versión en el extremo de Apple. En nuestro caso, agregar un «.1» adicional al final de las cadenas del número de versión de la aplicación permitió que se cargara con Application Loader.

Sin embargo, es realmente extraño / engañoso que el mensaje de error para esto sea «La aplicación que ha seleccionado no existe».

Yo estaba teniendo el mismo problema. Intenté cargar con el cargador de aplicaciones y luego obtuve errores descriptivos sobre la versión del paquete. Después de eliminar todo el info.plist de terceros de los pods y las bibliotecas estáticas, funcionará para cargar mi compilación.

Solucioné este problema. Tuve que actualizar mi OSX a 10.10.5 y XCode a 7.0.1. En XCode necesitas configurar algunas claves. Se requiere la clave NSAppTransportSecurity si su aplicación o juego necesita acceso a Internet. Después de esta configuración, funciona perfectamente desde xcode. Y no hay problema con iTunes Connect en vivo.

<key>UIRequiresFullScreen</key>
    <true/>

<key>NSAppTransportSecurity</key>
    <dict>
        <key>NSAllowsArbitraryLoads</key>
        <false/>
        <key>NSExceptionDomains</key>
        <dict>
            <key>domain.com</key>
            <dict>
                <key>NSExceptionAllowsInsecureHTTPLoads</key>
                <true/>
                <key>NSExceptionMinimumTLSVersion</key>
                <string>TLSv1.1</string>
                <key>NSExceptionRequiresForwardSecrecy</key>
                <false/>
                <key>NSIncludesSubdomains</key>
                <false/>
                <key>NSThirdPartyExceptionAllowsInsecureHTTPLoads</key>
                <false/>
                <key>NSThirdPartyExceptionMinimumTLSVersion</key>
                <string>TLSv1.1</string>
                <key>NSThirdPartyExceptionRequiresForwardSecrecy</key>
                <false/>
            </dict>
        </dict>
    </dict> 

Mi solución para problemas similares es el uso de Fastlane Tools https://fastlane.tools
Primero puede usar la herramienta GYM para construir / archivar su proyecto, y luego Pilot para enviarlo a iTunesConnect Testflight. Esta herramienta soluciona todos mis problemas con la firma, envío, etc. de código, así que puedo recomendarla.